If your ORTOVOX 3+ transceiver is running software version 2.1 it is being recalled by ORTOVOX

Earlier this month, ORTOVOX announced that some of their popular 3+ transceivers are due for a precautionary recall after a software error has been discovered that may prolong the search process. The German manufacturer said that “The error was identified and rectified in extensive internal tests. The new software version 2.2 will rectify the error.”

The recall will start on 25th May 2018 and is free of charge, find out more here.

In a release on their website, ORTOVOX informed customers of the fault:
“Feedback from our SAFETY ACADEMY PARTNERS has revealed that, in some rare situations, temporary disruption of the transmission function may occur on our 3+ avalanche transceivers running SOFTWARE VERSION 2.1. This can lead to prolongation of the search process. The reason for the disruption is a software error.
There have been no known accidents caused by the software error. However, as a precautionary measure to ensure our customers are not at risk, we are recalling all 3+ transceivers running software version 2.1. Devices affected by the recall may no longer be used without the required software update to version 2.2.”

How do I check if my ORTOVOX 3+ is running faulty software?

Reading the software version and serial number on your 3 + transceiver

 

This precautionary recall applies exclusively to ORTOVOX 3+ avalanche transceivers running software version 2.1. - no matter what color.

3+ devices running software versions 1.0, 1.1, 2.0, 2.2 and all other ORTOVOX avalanche transceivers (S1+, S1, ZOOM) are not affected.

Find out more here

ORTOVOX